Having static_cast<const SIInstrInfo *>(getTargetMachine().getSubtargetImpl()->getInstrInfo()) littered everywhere is horrible, so add a wrapper for it.
Details
Details
- Reviewers
- None
Diff Detail
Diff Detail
Event Timeline
Comment Actions
This could also be written as
getTargetMachine().getSubtarget<R600Subtarget>().getInstrInfo() and
then it's shorter but still leaves the full line. It's going to keep
changing for a bit so a helper function might be a bit premature.
-eric