Rename to allowsMisalignedMemoryAccess.
On R600, 8 and 16 byte accesses are mostly OK with 4-byte alignment,
and don't need to be split into multiple accesses. Vector loads with
an alignment of the element type are not uncommon in OpenCL code.
Paths
| Differential D4684
Add alignment value to allowsUnalignedMemoryAccess
ClosedPublic Authored by arsenm on Jul 26 2014, 2:24 PM.
Details
Summary Rename to allowsMisalignedMemoryAccess. On R600, 8 and 16 byte accesses are mostly OK with 4-byte alignment,
Diff Detail Event Timelinearsenm updated this object. Comment Actions I like the idea of adding the alignment as a function parameter, but I don't understand why you want to rename the function: Unaligned is generally the terminology I use for loads not naturally aligned. This revision is now accepted and ready to land.Jul 27 2014, 10:56 AM jroelofs added inline comments.
Revision Contents
Diff 11917 include/llvm/Target/TargetLowering.h
lib/CodeGen/SelectionDAG/LegalizeDAG.cpp
lib/CodeGen/SelectionDAG/SelectionDAG.cpp
lib/CodeGen/SelectionDAG/SelectionDAGBuilder.cpp
lib/Target/AArch64/AArch64ISelLowering.h
lib/Target/AArch64/AArch64ISelLowering.cpp
lib/Target/ARM/ARMISelLowering.h
lib/Target/ARM/ARMISelLowering.cpp
lib/Target/ARM/ARMSubtarget.h
lib/Target/Mips/Mips16ISelLowering.h
lib/Target/Mips/Mips16ISelLowering.cpp
lib/Target/Mips/MipsSEISelLowering.h
lib/Target/Mips/MipsSEISelLowering.cpp
lib/Target/PowerPC/PPCISelLowering.h
lib/Target/PowerPC/PPCISelLowering.cpp
lib/Target/R600/SIISelLowering.h
lib/Target/R600/SIISelLowering.cpp
lib/Target/SystemZ/SystemZISelLowering.h
lib/Target/SystemZ/SystemZISelLowering.cpp
lib/Target/X86/X86ISelLowering.h
lib/Target/X86/X86ISelLowering.cpp
lib/Target/XCore/XCoreISelLowering.cpp
test/CodeGen/R600/unaligned-load-store.ll
|
This comment needs a little attention... the type of the parameter is 'bool*' and not 'bool&'. Can you fix the comment while you're here? Something like "in the fourth argument, if provided and non-null".
Also, I'm with Hal on this one. 'Unaligned' is the terminology normally used for this sort of thing. Why are you renaming this?