SymbolInfo has some optional fields, which is a bad-smell
implementation. For now, we
- remove the optional field since we don't need them (we can probably add them back if we actually need them in the future)
- make SymbolInfo to be a class.
By this change, the code is more simplified.