- Add LLVM_ATTRIBUTE_UNUSED_RESULT used to slicing methods in order to emphasize that the slicing is not done in place.
- Change device memory slice function name from drop_front to slice in order to match the naming convention of llvm::ArrayRef and host memory slice.
- Change the parameter names of host memory slice functions to DropCount and TakeCount to match device memory slice declarations.
Details
Details
Diff Detail
Diff Detail
- Repository
- rL LLVM