This is an archive of the discontinued LLVM Phabricator instance.

Rename variables in gc_relocate related functions to follow LLVM's naming conventions.
ClosedPublic

Authored by chenli on May 11 2015, 2:23 PM.

Details

Summary

This patch is to rename some variables to CamelCase in gc_relocate related functions. There is no functionality change.

Diff Detail

Repository
rL LLVM

Event Timeline

chenli updated this revision to Diff 25511.May 11 2015, 2:23 PM
chenli retitled this revision from to Rename variables in gc_relocate related functions to follow LLVM's naming conventions..
chenli updated this object.
chenli edited the test plan for this revision. (Show Details)
chenli added reviewers: sanjoy, reames, AndyAyers.
chenli added a subscriber: Unknown Object (MLST).
sanjoy accepted this revision.May 11 2015, 2:37 PM
sanjoy edited edge metadata.

LGTM given that this is a renaming-only change.

Do you want me to check this in for you?

lib/Transforms/Scalar/RewriteStatepointsForGC.cpp
1094 ↗(On Diff #25511)

Another potential cleanup here -- CreateCall3 returns a CallInst so you can just do

Callinst *Reloc = ... CreateCall3

and elide of the cast<>s.

If you do this, please do that in a separate change.

This revision is now accepted and ready to land.May 11 2015, 2:37 PM

LGTM given that this is a renaming-only change.

Do you want me to check this in for you?

Yes, please! And thanks for doing it!

This revision was automatically updated to reflect the committed changes.