This patch correctly respects the -demangle option, and additionally adds a hidden -relative-address option allows input addresses to be relative to the module load address instead of absolute addresses into the image.
Diff Detail
Diff Detail
Event Timeline
Comment Actions
LGTM (after simplification suggested below).
lib/DebugInfo/PDB/PDBContext.cpp | ||
---|---|---|
53 | Please move it to a separate function std::string getFunctionName(uint64_t Address, PDBSymbol *FnSymbol, DINameKind NameKind); with a bunch of early-returns, and just do Result.FunctionName = getFunctionName(Address, Symbol.get(), Specifier.FNKind); |
Comment Actions
Just for the linkage name right? I don't think we want to add test for
-relative-address if we hide it and plan to remove it anyway
Please move it to a separate function
with a bunch of early-returns, and just do