It's a chunk from D26390
This is a debatable change, but would like to see applied. :) It has two drivers...
- User specify the desired output directory as command line parameter. Then we take this value and compute another one from it (append a random like directory to it). After this we consider the new value as output directory... Before this change, it was named 'output directory' what was given by the user (or the default values), and 'target directory' or 'report directory' what we generated from it. But I think it's the same thing. Therefore would call it the same name. And store in the same place.
- The other points comes from the code perspective. We passing around all relevant parameters via the parsed command object, except the output directory location. This change eliminate the need to pass multiple parameters for many methods.