Using ArrayRef in annotateValueSite's parameter instead of using an array and it's size. This is one of cleanups suggested by Sean Silva in http://reviews.llvm.org/D17864.
Details
Details
Diff Detail
Diff Detail
- Repository
- rL LLVM
Event Timeline
Comment Actions
Thank! LGTM. A couple minor suggestions inline.
lib/ProfileData/InstrProf.cpp | ||
---|---|---|
631 ↗ | (On Diff #51964) | Would VD be a better name instead of I? |
unittests/ProfileData/InstrProfTest.cpp | ||
334 ↗ | (On Diff #51964) | I believe this can be just makeArrayRef(VD0Sorted).slice(2) without introducing the temporary or having to explicitly give a size. |