Skip to content

Commit 702ffea

Browse files
committedJan 19, 2018
[Refactor] Use enum instead of magic number in handleX86ForceAlignArgPointerAttr, NFC
Differential revision: https://reviews.llvm.org/D42227 llvm-svn: 322918
1 parent dc4b3e8 commit 702ffea

File tree

1 file changed

+1
-1
lines changed

1 file changed

+1
-1
lines changed
 

‎clang/lib/Sema/SemaDeclAttr.cpp

+1-1
Original file line numberDiff line numberDiff line change
@@ -5554,7 +5554,7 @@ static void handleX86ForceAlignArgPointerAttr(Sema &S, Decl *D,
55545554
// Attribute can only be applied to function types.
55555555
if (!isa<FunctionDecl>(D)) {
55565556
S.Diag(Attr.getLoc(), diag::warn_attribute_wrong_decl_type)
5557-
<< Attr.getName() << /* function */0;
5557+
<< Attr.getName() << ExpectedFunction;
55585558
return;
55595559
}
55605560

0 commit comments

Comments
 (0)
Please sign in to comment.