This patch also removes the SCEV variants of getStepVector() since they have no uses after the refactoring. This change was suggested in the review of D21620.
Details
Details
Diff Detail
Diff Detail
- Repository
- rL LLVM
Event Timeline
Comment Actions
Great clean-up! I have a few minor suggestions below.
lib/Transforms/Vectorize/LoopVectorize.cpp | ||
---|---|---|
2207–2209 ↗ | (On Diff #62395) | Can we do a single look-up in an assert-enabled build? I.e. assert(II != end() ...) |
2216 ↗ | (On Diff #62395) | Init is a bit confusing in this context. How about ScalarIV? I think that you can also move this down to after the call to createVectorIntInductionPHI. |
4451 ↗ | (On Diff #62395) | I would rename II to ID or something since it's not an iterator but an InductionDescriptor. |
Comment Actions
Thanks, Adam! All your suggestions look good to me so I'll make those changes before committing.