The patch implements microMIPS32r6 LLE, LUI, LW and LWE instructions.
Details
Diff Detail
Event Timeline
LGTM with some nits
lib/Target/Mips/Disassembler/MipsDisassembler.cpp | ||
---|---|---|
288–290 | Indentation | |
1347–1349 | Indentation | |
lib/Target/Mips/MicroMips32r6InstrFormats.td | ||
201–238 | These don't follow the naming convention. As mentioned in D11801, please break out the parts of addr into variables. | |
lib/Target/Mips/MicroMips32r6InstrInfo.td | ||
295 | Naming convention | |
295–321 | I don't see a need for separate LOAD_WORD and LOAD_UPPER_IMM classes. Why not just have LW_MMR6_DESC and LUI_MMR6_DESC? | |
299 | Indentation | |
310 | Naming convention | |
311 | Indentation | |
lib/Target/Mips/MipsInstrInfo.td | ||
1221–1222 | This is from an earlier patch but please correct the indentation while you're changing it. |
Closed by commit rL247017: [mips][microMIPS] Implement LLE, LUI, LW and LWE instructions
Indentation