HomePhabricator

[OMPT] Rename ompt_mutex_impl_t to kmp_mutex_impl

Description

[OMPT] Rename ompt_mutex_impl_t to kmp_mutex_impl

The defintion is not part of the spec and thus should not have the prefix
"ompt_" but rather a prefix that indicates that this is implementation
specific.

Differential Revision: https://reviews.llvm.org/D41166