HomePhabricator

Fix Hwloc API Incompatibility

Description

Fix Hwloc API Incompatibility

Older Hwloc libraries (< 1.10.0) don't offer the HWLOC_OBJ_NUMANODE nor
HWLOC_OBJ_PACKAGE types. Instead they are named HWLOC_OBJ_NODE and
HWLOC_OBJ_SOCKET instead. This patch just defines the newer names based on
the older names when using an older Hwloc.

Differential Revision: https://reviews.llvm.org/D32496

Details

Committed
jlpeytonApr 25 2017, 12:04 PM
Differential Revision
D32496: Fix Hwloc API Incompatibility
Branches
Unknown
Tags
Unknown