HomePhabricator

[OpenMP] Remove OMP spec versioning

Description

[OpenMP] Remove OMP spec versioning

Remove all older OMP spec versioning from the runtime and build system.

Patch by Terry Wilmarth

Differential Revision: https://reviews.llvm.org/D64534

Details

Committed
jlpeytonJul 12 2019, 2:45 PM
Differential Revision
D64534: Remove OMP spec versioning
Parents
rL365962: Remove __VERSION__
Branches
Unknown
Tags
Unknown

Event Timeline

I've noticed some tests in libomp still have the REQUIRES: openmp-4.5 or REQUIRES: openmp-4.0 constraints. Given that the REQUIRES: openmp-5.0 have been removed I am wondering whether this may be an oversight. Those tests are currently not run, as lit considers them unsupported.

I've noticed some tests in libomp still have the REQUIRES: openmp-4.5 or REQUIRES: openmp-4.0 constraints. Given that the REQUIRES: openmp-5.0 have been removed I am wondering whether this may be an oversight. Those tests are currently not run, as lit considers them unsupported.

Thanks for pointing this out. I've removed the REQUIRES lines in r366341.