HomePhabricator

[scudo][standalone] NFC corrections

Description

[scudo][standalone] NFC corrections

Summary:
A few corrections:

  • rename TransferBatch::MaxCached to getMaxCached to conform with the style guide;
  • move getBlockBegin from Chunk:: to Allocator::: I believe it was a fallacy to have this be a Chunk method, as chunks' relationship to backend blocks are up to the frontend allocator. It makes more sense now, particularly with regard to the offset. Update the associated chunk test as the method isn't available there anymore;
  • add a forgotten \n to a log string;
  • for releaseToOs, instead of starting at 1, start at 0 and continue on BatchClassId: in the end it's identical but doesn't assume a particular class id for batches;
  • change a CHECK to a reportOutOfMemory: it's a clearer message

Reviewers: hctim, morehouse, eugenis, vitalybuka

Reviewed By: hctim

Subscribers: delcypher, #sanitizers, llvm-commits

Tags: #llvm, #sanitizers

Differential Revision: https://reviews.llvm.org/D64570

Details

Committed
cryptoadJul 11 2019, 12:55 PM
Reviewer
hctim
Differential Revision
D64570: [scudo][standalone] NFC corrections
Parents
rL365815: [NFC] Revisited tests for D64285
Branches
Unknown
Tags
Unknown