HomePhabricator

VERSION_GREATER_EQUAL not supported in llvm cmake.

Description

VERSION_GREATER_EQUAL not supported in llvm cmake.

Patch https://reviews.llvm.org/D56329 caused build failures for me when
building on Windows because of the use of cmake operator
'VERSION_GREATER_EQUAL' which isn't supported in older versions of cmake. The
llvm website states that minimum required version of cmake for building llvm is
3.4.3 https://llvm.org/docs/CMake.html

Differential Revision: https://reviews.llvm.org/D57326