Rename this variable.
SC didn't make much sense. We don't seem to have a clear convention,
but IS sounds good here because it emphasizes that it is an input
section (this is one place in the code where we are dealing with both
input sections and output sections at the same time so that extra
emphasis makes it a bit clearer).