[CMake] Update to requiring CMake 3.4.3

Description

[CMake] Update to requiring CMake 3.4.3

Summary:
This is as per the discussions on developer lists:

http://lists.llvm.org/pipermail/llvm-dev/2016-April/098780.html
http://lists.llvm.org/pipermail/llvm-dev/2016-May/100058.html

Subscribers: llvm-commits

Differential Revision: http://reviews.llvm.org/D20822

Details

Committed
cbienemanMay 31 2016, 1:21 PM
Differential Revision
D20822: [CMake] Update to retiring CMake 3.4.3
Parents
rL271324: Use C++11 atomics for ticket locks implementation
Branches
Unknown
Tags
Unknown