Initial support for the align_value attribute

Description

Initial support for the align_value attribute

This adds support for the align_value attribute. This attribute is supported by
Intel's compiler (versions 14.0+), and several of my HPC users have requested
support in Clang. It specifies an alignment assumption on the values to which a
pointer points, and is used by numerical libraries to encourage efficient
generation of vector code.

Of course, we already have an aligned attribute that can specify enhanced
alignment for a type, so why is this additional attribute important? The
problem is that if you want to specify that an input array of T is, say,
64-byte aligned, you could try this:

typedef double aligned_double attribute((aligned(64)));
void foo(aligned_double *P) {
  double x = P[0]; // This is fine.
  double y = P[1]; // What alignment did those doubles have again?
}

the access here to P[1] causes problems. P was specified as a pointer to type
aligned_double, and any object of type aligned_double must be 64-byte aligned.
But if P[0] is 64-byte aligned, then P[1] cannot be, and this access causes
undefined behavior. Getting round this problem requires a lot of awkward
casting and hand-unrolling of loops, all of which is bad.

With the align_value attribute, we can accomplish what we'd like in a well
defined way:

typedef double *aligned_double_ptr attribute((align_value(64)));
void foo(aligned_double_ptr P) {
  double x = P[0]; // This is fine.
  double y = P[1]; // This is fine too.
}

This attribute does not create a new type (and so it not part of the type
system), and so will only "propagate" through templates, auto, etc. by
optimizer deduction after inlining. This seems consistent with Intel's
implementation (thanks to Alexey for confirming the various Intel-compiler
behaviors).

As a final note, I would have chosen to call this aligned_value, not
align_value, for better naming consistency with the aligned attribute, but I
think it would be more useful to users to adopt Intel's name.

Details

Committed
hfinkelOct 2 2014, 2:21 PM
Parents
rL218909: Remove unused function attribute params.
Branches
Unknown
Tags
Unknown