ValueMapper: Rename RF_MoveDistinctMDs => RF_ReuseAndMutateDistinctMDs, NFC
Rename the RF_MoveDistinctMDs flag passed into MapValue and
MapMetadata to RF_ReuseAndMutateDistinctMDs in order to more
precisely describe its effect and clarify the header documentation.
Found this while helping to investigate PR48841, which pointed out an
unsound use of the flag in CloneModule(). For now I've just added a
FIXME there, but I'm hopeful that the new (more precise) name will
prevent other similar errors.