HomePhabricator

Rename APIs in unittests/AST/Language.h in preparation to share them

Authored by gribozavr on May 29 2020, 5:12 AM.

Description

Rename APIs in unittests/AST/Language.h in preparation to share them

Summary:
Declaring these helpers in the ast_matcher namespace in the clangAST
unit test seems inappropriate -- neither these helpers, nor clangAST have
anything to do with AST matchers. Therefore, I moved these helpers to
the clang namespace.

Declaring another typedef called "ArgVector" is not a good idea -- we
already have both "ArgVector", "ArgsVector", and "ArgList". I expanded
it into the underlying type.

Declaring another enum called "Language" is not a good idea because we
arleady have the "clang::Language" enum. I renamed it to
"TestLanguage".

Similarly, I renamed "getBasicRunOptionsForLanguage" to
"getCommandLineArgsForTesting" to explain the semantics better (what are
"run options"?) and not repeat types in the function name
("ForLanguage").

Reviewers: shafik, rengolin, sammccall

Reviewed By: sammccall

Subscribers: gribozavr2, sammccall, martong, cfe-commits

Tags: #clang

Differential Revision: https://reviews.llvm.org/D80786

Details

Committed
gribozavrMay 29 2020, 5:25 AM
Reviewer
sammccall
Differential Revision
D80786: Rename APIs in unittests/AST/Language.h in preparation to share them
Parents
rGab4d02cf2659: [clang] [MinGW] Fix libunwind extension
Branches
Unknown
Tags
Unknown