HomePhabricator

[darwin][driver] isMacosxVersionLT should check against the minimum supported…
d0b68290c81cUnpublished

Authored by arphaman on Jun 29 2020, 10:23 AM.

Unpublished Commit · Learn More

Not On Permanent Ref: This commit is not an ancestor of any permanent ref.

Description

[darwin][driver] isMacosxVersionLT should check against the minimum supported OS version

This change ensures that the Darwin driver doesn't add unsupported libraries to the link
invocation when linking the Apple Silicon macOS slice.

rdar://61011136

Differential Revision: https://reviews.llvm.org/D82696

(cherry picked from commit f7a14514ee63dc2ab9558c50254efb8ac2ad7cc6)