HomePhabricator

[clangd] NFC: Use deprecated grpc++ headers for compatibility

Authored by kbobyrev on May 8 2020, 2:01 AM.

Description

[clangd] NFC: Use deprecated grpc++ headers for compatibility

Summary:
Ubuntu 18.04 and older versions do not provide latest gRCP packages and the
ones that are in the repository use deprecated headers. Use these headers to
make builds possible.

https://packages.ubuntu.com/bionic/amd64/libgrpc++-dev/filelist

Reviewers: sammccall

Reviewed By: sammccall

Subscribers: ilya-biryukov, MaskRay, jkorous, arphaman, kadircet, usaxena95, cfe-commits

Tags: #clang

Differential Revision: https://reviews.llvm.org/D79487

Details

Committed
kbobyrevMay 8 2020, 2:04 AM
Reviewer
sammccall
Differential Revision
D79487: [clangd] NFC: Use deprecated grpc++ headers for compatibility
Parents
rG6ab09e717745: Fix a failing test.
Branches
Unknown
Tags
Unknown