HomePhabricator

[ELF] Rename BaseCommand to SectionCommand. NFC

Authored by MaskRay on Thu, Nov 25, 8:24 PM.

Description

[ELF] Rename BaseCommand to SectionCommand. NFC

BaseCommand was picked when PHDRS/INSERT/etc were not implemented. Rename it to
SectionCommand to match sectionCommands and make it clear that the commands
are used in SECTIONS (except a special case for SymbolAssignment).

Also, improve naming of some BaseCommand variables (base -> cmd).

Details

Committed
MaskRayThu, Nov 25, 8:24 PM
Parents
rG2f07534263ca: [NFC] Fix typo in 95875d246acb
Branches
Unknown
Tags
Unknown