[clangd] Rename DiagnosticsConsumer -> ClangdServer::Callbacks, and make it optional
This reflects its current function better and avoids confusion with clang::DiagnosticConsumer.
The old name/constructor is left around temporarily for compatibility.
(Metagame: merging with out-of-tree changes is harder than usual this month)
Subscribers: ilya-biryukov, javed.absar, MaskRay, jkorous, arphaman, kadircet, usaxena95, cfe-commits
Differential Revision: https://reviews.llvm.org/D73346