HomePhabricator

[lld][WebAssembly] Use a more meaningful name for stub functions

Authored by sbc100 on Jan 16 2020, 2:36 PM.

Description

[lld][WebAssembly] Use a more meaningful name for stub functions

When we generate these stub functions on signature mismatches give
them a more meaningful name so that when people see this in stack
traces is gives a clue as the what is going on.

See: https://github.com/emscripten-core/emscripten/issues/10226

Differential Revision: https://reviews.llvm.org/D72881