[lldb][NFC] Rename the second ValueObjectManager to ValueObjectUpdater and…

Authored by teemperor on Feb 24 2021, 4:26 AM.


[lldb][NFC] Rename the second ValueObjectManager to ValueObjectUpdater and remove the dead code

ValueObject.h contains the ValueObject::ValueObjectManager type which is
just a typedef for the ClusterManager that takes care of the whole ValueObject
memory management. However, there is also ValueObjectManager defined in the
same header which is only used in the curses UI implementation and consists
mostly of dead and completely untested code.

This code been around since a while (it was added in 2016 as
8369b28da0750129ababae357bea98940800a0e0), so I think we shouldn't just revert
the whole patch.

Instead this patch just moves the class to its own header that it isn't just
hiding in the ValueObject header and renames it to ValueObjectUpdater that it
at least has a unique name (which I hope also slightly better reflects the
purpose of this class). I also deleted all the dead code branches and functions.

Reviewed By: #lldb, mib, JDevlieghere

Differential Revision: https://reviews.llvm.org/D97287