HomePhabricator

[mlir][NFC] Rename `MemRefType::getMemorySpace` to `getMemorySpaceAsInt`

Authored by vinograd47 on Feb 25 2021, 7:54 AM.

Description

[mlir][NFC] Rename MemRefType::getMemorySpace to getMemorySpaceAsInt

Just a pure method renaming.

It is a preparation step for replacing "memory space as raw integer"
with more generic "memory space as attribute", which will be done in
separate commit.

The MemRefType::getMemorySpace method will return Attribute and
become the main API, while getMemorySpaceAsInt will be declared as
deprecated and will be replaced in all in-tree dialects (also in separate
commits).

Reviewed By: mehdi_amini, rriddle

Differential Revision: https://reviews.llvm.org/D97476

Details

Committed
vinograd47Mar 2 2021, 12:08 AM
Reviewer
mehdi_amini
Differential Revision
D97476: [mlir][NFC] Rename `MemRefType::getMemorySpace` to `getMemorySpaceAsInt`
Parents
rG4444b343d7e2: [IR] Use range-based for loops (NFC)
Branches
Unknown
Tags
Unknown