HomePhabricator

[AMDGPU] Rename llvm.amdgcn.msaa.load to llvm.amdgcn.msaa.load.x

Authored by critson on Mar 3 2021, 12:09 AM.

Description

[AMDGPU] Rename llvm.amdgcn.msaa.load to llvm.amdgcn.msaa.load.x

While the underlying instruction is called image_msaa_load,
the resource must be x component only.
Rename the intrinsic for clarity.

Reviewed By: foad

Differential Revision: https://reviews.llvm.org/D97829

Details

Committed
critsonMar 3 2021, 12:30 AM
Reviewer
foad
Differential Revision
D97829: [AMDGPU] Rename llvm.amdgcn.msaa.load to llvm.amdgcn.msaa.load.x
Parents
rG09c35739035e: [FileCheck] Do not skip end of line in diagnostics
Branches
Unknown
Tags
Unknown