HomePhabricator

[GWP-ASan] Add GWP_ASAN_ prefix to macros.

Authored by hctim on Nov 25 2019, 12:25 PM.

Description

[GWP-ASan] Add GWP_ASAN_ prefix to macros.

Summary:
When platforms use their own LIKELY() definitions, it can be quite
troublesome to ensure they don't conflict with the GWP-ASan internal
definitions. Just force the GWP_ASAN_ prefix to help this issue.

Reviewers: eugenis

Reviewed By: eugenis

Subscribers: #sanitizers, llvm-commits, cferris, pcc

Tags: #sanitizers, #llvm

Differential Revision: https://reviews.llvm.org/D70683

Details

Committed
hctimNov 25 2019, 12:27 PM
Reviewer
eugenis
Differential Revision
D70683: [GWP-ASan] Add GWP_ASAN_ prefix to macros.
Parents
rG85e4f5bcf6aa: [PowerPC] Rename DarwinDirective to CPUDirective (NFC)
Branches
Unknown
Tags
Unknown