HomePhabricator

[ELF] Rename canRelax to toExecRelax. NFC

Authored by MaskRay on Jul 8 2020, 10:27 AM.

Description

[ELF] Rename canRelax to toExecRelax. NFC

In the absence of TLS relaxation (rewrite of code sequences),
there is still an applicable optimization:

[gd]: General Dynamic: resolve DTPMOD to 1 and/or resolve DTPOFF statically

All the other relaxations are only performed when transiting to
executable (!config->shared).
Since [gd] is handled differently, we can fold !config->shared into canRelax
and simplify its use sites. Rename the variable to reflect to new semantics.

Reviewed By: grimar, psmith

Differential Revision: https://reviews.llvm.org/D83243

Details

Committed
MaskRayJul 8 2020, 10:27 AM
Reviewer
grimar
Differential Revision
D83243: [ELF] Rename canRelax to toExecRelax. NFC
Parents
rGe89c075f3251: [test] Run llvm/test/**/*.yaml & don't run llvm/test/**/*.cxx (not exist)
Branches
Unknown
Tags
Unknown