Add a less ambiguous macro for Android version.
Android has a handful of API levels relevant to developers described
__ANDROID_API__ is too vague and confuses a lot of people. Introduce
a new macro name that is explicit about which one it represents. Keep
the old name around because code has been using it for a decade.