HomePhabricator

[Driver, CodeGen] rename options to disable an FP cast optimization

Description

[Driver, CodeGen] rename options to disable an FP cast optimization

As suggested in the post-commit thread for rL331056, we should match these
clang options with the established vocabulary of the corresponding sanitizer
option. Also, the use of 'strict' is well-known for these kinds of knobs,
and we can improve the descriptive text in the docs.

So this intends to match the logic of D46135 but only change the words.
Matching LLVM commit to match this spelling of the attribute to follow shortly.

Differential Revision: https://reviews.llvm.org/D46236

Details

Committed
spatelApr 30 2018, 11:19 AM
Differential Revision
D46236: [Driver, CodeGen] rename options to disable an FP cast optimization
Branches
Unknown
Tags
Unknown