HomePhabricator

[Driver] Test for correct '--version' suggestion

Description

[Driver] Test for correct '--version' suggestion

Summary:
The llvm::OptTable::findNearest bug fixed in
https://reviews.llvm.org/D41873 manifested itself as the following
erroneous message when invoking Clang:

clang -version
clang-6.0: error: unknown argument '-version', did you mean 'version'?

Add a test to catch any future regressions to the now correct behavior,
which asks "did you mean '--version'?".

Test Plan: check-clang

Reviewers: v.g.vassilev, teemperor, ruiu, jroelofs, yamaguchi

Reviewed By: v.g.vassilev

Subscribers: cfe-commits

Differential Revision: https://reviews.llvm.org/D41912

Details

Committed
modocacheJan 10 2018, 12:23 PM
Reviewer
v.g.vassilev
Differential Revision
D41912: [Driver] Test for correct '--version' suggestion
Branches
Unknown
Tags
Unknown