User Details
- User Since
- Oct 12 2017, 12:47 AM (284 w, 3 d)
Sep 10 2018
Moved lock calls out of OMPT code
Aug 15 2018
The removal of the idle callback was done in D48362 and is removed from this Patch.
Aug 1 2018
Jul 16 2018
Jul 11 2018
Jul 4 2018
Jun 25 2018
Add comment explaining the use of alloca()
Use alloca() to force availability of frame pointer
Jun 20 2018
Jun 18 2018
Add a testcase that calls the runtime entry points when OMPT is not enabled.
Jun 13 2018
Add check to ompt_get_state()
Jun 11 2018
Add support for OMPT return addresses.
Also test them.
Move ompt_enabled.enabled checks out of internal functions
Jun 6 2018
Use a stride of 3 in testcase loop
Use tc for the iteration count
Address Jonas' comments:
Jun 4 2018
Use kmpc_omp_task() instead of changing kmp_omp_task().
Apr 30 2018
Remove formatting change unrelated to this revision.
Mar 7 2018
Fix uninitialized step count
Mar 1 2018
Implement suggestions
Feb 28 2018
Reformat
Reformat using git-clang-format
Applying clang-format to callback.h does not improve readability
Feb 22 2018
Fix small copy-and-paste mistake
Update Formatting
Feb 21 2018
Fix indentation
Feb 15 2018
Add some comments to checks and reformat as suggested
Feb 14 2018
Check task_ids in task_types.c testcase
Check ompt_get_partition_place_nums().
Fix small bug in implementation of ompt_get_partition_place_nums(): return correct length.
Exclude formatting of ompt_try_start_tool
Implemented suggestions
Jan 25 2018
Jan 24 2018
Merge D42470 into this revision
Jan 17 2018
Implemented suggestions
Use omp_control_tool for an additional check
Jan 11 2018
Added testcase
Jan 10 2018
Added reference to reported issue in comments
Updated testcase
Implemented suggestion
Added Testcase
Dec 23 2017
Updated revision
Dec 21 2017
Removed unnecessary definition.
Implemented suggestion
Dec 14 2017
Implemented suggestion
Added testcase
Dec 13 2017
Implemented suggestions.
Include another return address handling fix
Fixed Diff
Fix formatting
Implemented all suggestions.
The use of UNSUPPORTED seems to be necessary. I updated the Diff.