- User Since
- Jan 26 2015, 1:33 PM (142 w, 2 d)
Jun 25 2017
Thanks for letting me know. Will update for both.
- It seems the llvm test-suite today only checks for SMALL_PROBLEM_SIZE, occasionally LARGE_PROBLEM_SIZE and for SPEC you can choose the size manually. Do you plan to change the test-suite for the new sizes? We should probably do further discussions there.
I added these options only for Polybench. Have not inspected the other benchmarks. I would like to discuss how we can map these sizes for other benchmarks? One we agree upon something, I can make the changes for the test-suite.
- Do you plan to set any rules/expectations on those new sizes? (Something like "mini" finished in half the time than "small")
I have not thought about it yet.
- Out of interest: Why do you need finer control over the problem sizes?
I am working with Polybench, which supports multiple input dataset sizes. I did these changes for my experiments and thought it would be better to upload the changes for the community.
I agree with you. I was planning to add such a flag for all the sizes "--datasize=mini|small|standard|large|extra_large". Did not do it for compatibility. Thanks for the suggestion about aliasing for backward compatibility. If we agree on adding such an option, I think "--testdatasize" will be appropriate. And I would argue about using a common flag like this one for all for all data sizes instead of using "--make-param" flag as pointed out by @cmatthews.
Jun 19 2017
Jul 18 2016
Jul 15 2016
Updated as per review comments.
I tested this with lnt and there are no crashes. However, there exists few failed cases with and without this patch.
Jul 11 2016
Updated according to review comments.
Jul 8 2016
Updated the patch with necessary changes. Added unit test cases.
Fixed corrupt memory issues due to isl objects. Added test cases.
Jul 6 2016
Jul 3 2016
Jun 27 2016
Jun 17 2016
Jun 8 2016
Jun 7 2016
Thanks a lot. I will experiment with it.
Created a new pass to calculate dependences for a function D21105.
We can introduce similar changes over their.
Please review and comment.
Thank you for your inputs. I have updated the patch accordingly.
Please let me know if this set of test cases is not enough.
Jun 3 2016
Follow variable naming convention.
Delete ScopBuilder after new in ScopInfoRegionPass::runOnRegion.
Jun 2 2016
Rebased over patch D20831 which is not committed yet.
This patch only renames ScopInfo class to ScopBuilder. This change is required because ScopBuilder class only creates SCoP objects, it is not a container class to store them. Valid SCoP objects will be contained in ScopInfoRegionPass and ScopInfoWrapperPass.
Jun 1 2016
Separated renaming of ScopInfo to ScoBuilder and adding a new pass ScopInfoWrapper pass into two patches.
May 31 2016
May 30 2016
- Removed releaseMemory and print functions from ScopInfo class as they are not required any more.
I have done the changes you requested. Have arc for the new patch.
- Decouple Scop building logic from pass logic
- Removed createScopInfo function and inlined code into ScopInfo constructor.
May 28 2016
Jul 29 2015
Filter UnDef size values in Scop Detection.
Yes I saw that now. Thanks for catching it so quickly. Now all the test cases are passing.
Jul 28 2015