- User Since
- Apr 3 2015, 11:14 AM (250 w, 1 d)
Feb 27 2017
Seems fine, though I think it would have to be programUndefinedIfFullPoison.
Apr 21 2016
Nov 5 2015
Aug 28 2015
Aug 26 2015
Use isSignedIntSetCC() to simplify logic.
Aug 21 2015
I think we'd need a change in loop unrolling for this. Here's an example, where the trip count is divergent:
Aug 14 2015
Thank you to Sanjoy for the review!
Aug 13 2015
Aug 12 2015
Aug 11 2015
Address Sanjoy's comments.
Aug 7 2015
Aug 5 2015
Closed by commit at http://reviews.llvm.org/rL244166 .
Differential Revision: http://reviews.llvm.org/D11774
Another tiny improvement to the comments.
Tiny comment improvement. Thanks to Jingyue for pointing out that the comment was ambiguous.
Add @notkernel2 test.
Address eliben's comments.
Jul 28 2015
Jul 27 2015
Thank you to Sanjoy and Andy for the review.
Tiny update to comments.
Improve handling of case where V is a ConstantExpr in createSCEV.
Jul 24 2015
Jul 23 2015
Jul 21 2015
Change comments to avoid referring to what this change does as "analysis".
I'd wait to see what reames thinks, but this looks good to me.
Jul 20 2015
Comments addressed and ran clang-format.
Jul 19 2015
Jul 18 2015
Thanks for the comments, Sanjoy. I'll update the code with name changes Monday.
Jul 16 2015
Addresses David Majnemer's comment on shl.
Jul 15 2015
Added and used isGuaranteedToTransferExecutionToSuccessor (is there a better name?). Also slight improvement to comments.
Address Sanjoy's initial comments.
Jul 14 2015
Jun 30 2015
Jun 26 2015
Committed as revision 240438.
Jun 22 2015
Jun 16 2015
Jun 12 2015
Add comment on MaxSize.
Jun 10 2015
Change unswitching cost calculation from std::min(NumInstructions, 5 * NumBlocks) to NumInstructions.
The real, fixed revision is at D10376. Ignore this one.
Phabricator tells me to make a new revision instead, this time adding llvm-commits as a subscriber, so I'll do that.
Jun 9 2015
Looks good to me.
May 27 2015
May 20 2015
May 19 2015
May 18 2015
May 14 2015
Remove speculation flag and call from PassManagerBuilder.
Update comments on speculation.
May 7 2015
Change first parameter type of ComputeSpeculationCost to Instruction *.
May 6 2015
I promised to get back to you on a few things. I tried these versions overnight:
Use TTI for speculation cost of whitelisted instructions.
May 5 2015
Use getSingleSuccessor() more.
Added and used BasicBlock::getSingleSuccessor().
Improved flag descriptions.
Apr 30 2015
Apr 29 2015
Apr 14 2015
I added some comments not directly related to the patch, since you're the author of the whole pass, but feel free to ignore those parts for this patch.