- User Since
- Mar 11 2016, 1:45 PM (225 w, 2 d)
Tue, Jun 9
I admittedly don't know Clang's naming scheme, so feel free to ignore this, but I dislike the change to *.column.major.* because it feels like both are changeable parameters (i.e. column/row major/minor are two different axes). To anyone who knows what they're looking for they would understand that this doesn't make any sense, but the potential remains. I'm not sure that dropping the major portion makes any sense either because it might seem like you're promising loads and stores no matter the storage order (e.g. llvm.matrix.column.load might seem like it promises a column load even if the matrix is row major, which isn't the intent). Removing the . between them is an option but then it's not that much different from the original columnwise, unless "in line with Clang's naming" means using "column major" instead of "column-wise". Maybe I'm just putting too much meaning into the . too, but I'd rather mention it and be told it's fine than not say anything :)
Jun 2 2020
I don't have commit access, so yes. Please and thank you!
Jun 1 2020
Update names as per discussion.
Ok, I'll make the changes.
May 29 2020
My concern using rows/columns in any of the argument names is that one of the dimensions changes from rows to columns, but you're right that perhaps outer isn't particularly descriptive enough and would require reading the overview instead of being able to understand it from just the signature.
May 28 2020
Theoretically, renaming the arguments from (M, N, K) to (M, K, N) doesn't break compatibility but updates the names to match BLAS, though the argument order no longer matches BLAS.