- User Since
- Jun 22 2020, 11:08 PM (18 w, 3 d)
Thu, Oct 22
Great! To my understanding, if there are lifetime informations, the behavior of this patch is same with the behavior of previous implementation. Is my understanding right?
Sat, Oct 10
Fri, Oct 9
Thu, Oct 8
Thanks for your patch! It mentions some bugs about allocas we need to handle in the future.
Sep 28 2020
Sep 27 2020
rename wouldOptimize to ReuseFrameSlot.
Sep 25 2020
instead OptLevel in CoroSplit with bool to control whether the compiler would optimize a coroutine.
Sep 24 2020
Remove unnecessary headers and declarations.
Sep 22 2020
Change the type of OptLevel in Coro Split Passes as unsigned instead of PassBuilder::OptimizationLevel.
- Remove the feature that we can pass optimization level to opt tool like -passes='coro-split<On>'
- remove redundant addFieldForAlloca and addField
Sep 21 2020
- Move all the implementation details into addFieldForAllocas function.
- Change the type of ForSpill member of Field from pointer to a SmallVector of Spill.
Sep 20 2020
Sep 17 2020
Gate this optimization under optimization level and put the optimization code into a helper class.
Sep 14 2020
Sep 13 2020
Sep 3 2020
Aug 26 2020
Aug 18 2020
Aug 12 2020
@RKSimon , gentle ping~
Aug 6 2020
Update test case
Aug 5 2020
Create BitCastInst directly instead of using IRBuilder
Due to my mistake, the diff updated before is a draft. It is terribly sorry if it confuses any one...
Aug 3 2020
Aug 2 2020
Jul 30 2020
Jul 29 2020
Jul 28 2020
Jul 22 2020
Jul 20 2020
Jul 19 2020
Jun 28 2020
Hi @modocache ，may I ask for your option about this patch?
re-upload the patch due to previous misuse of Phabricator , sorry..
Because of D82029, the promise_type::final_suspend() should declare with noexcept specifier .