Since Charlie has completed his internship before LGTM, I'll commit this on his behalf.
Thu, Aug 1
Wed, Jul 31
Fri, Jul 26
Thu, Jul 25
Wed, Jul 24
Jul 23 2019
Jul 22 2019
- Use !=ET_REL
- Add a test case for ET_CORE
Jul 20 2019
Adding ‘FORCE’ makes this not user overridable, which is the whole point of this being a cache variable.
- Override LLVM_EXTERNAL_<proj>_SOURCE_DIR when it is empty.
https://github.com/llvm/llvm-project/blob/master/llvm/docs/CMake.rst and some other places in the codebase refer to the type as PATH.
Jul 18 2019
Jul 15 2019
- Make FramePointerKind enum class.
- Replace two if-else-if blocks to switch statements.
- Address reviewer's comments.
Jul 14 2019
Do you find another use case of printDynamicString? If yes, can you name it?
- Replace printDynamicString with getDynamicString.
- Change tests accordingly.
Jul 12 2019
- rebase after D64294.
Jul 11 2019
Jul 10 2019
Jul 9 2019
Jul 8 2019
Thank you for capturing that. The added new line in the previous revision is for GNU output. I should have done what LLVM output did: add a prefixing new line.
Jul 3 2019
Jul 2 2019
Jul 1 2019
My comment on your first version of this patch is about the potential code duplication. Now the codeview concern of the code duplication has been addressed.
The current version doesn't look bad to me. Do you think the initial version is better?
The expected client for this new symbolizeCode interface is for archive members and COFF is unlikely to symbolize plain object files for the moment.
I think the concern here the code movement for removing the potential duplication puts some untested code in the path for DWARF. I assume if there is a need for the COFF archive member symbolization we could easily deduplicate the code in the patch for COFF?
Jun 28 2019
Jun 27 2019
Jun 26 2019
I don't think it's a loss of functionality versus the previous version which creates DWARFContext even for COFF object (not work obviously). This version still does not work for COFF archive but looks a little bit more reasonable. IMHO, we should have no or all support for COFF archive, not partial support. I could either
Jun 25 2019
Jun 24 2019
- address reviewer's comments.
Jun 23 2019
Hi @MaskRay, does this version look good to you?
Jun 21 2019
To help writing up the discussion thread, I'm trying to gather some data on how each target handle the case with GNU objdump. Weird that I could not reproduce the results @MaskRay @peter.smith was able to obtain. This is not to show favor for either choice but to understand the current situation on GNU side so we make a sensible decision.
Jun 20 2019
Sorry for doing this. It is very late in my timezone, but I think I have to mark it as "Request Changes" as I saw it accepted and I really don't want it to be committed...
If you all agree bar2@plt-0x20 is less ideal and our .plt is better, I'm not sure why you want to copy the behavior of GNU objdump. I believe this belongs to the aesthetical area where 100% compatibility is not necessary. Programs/shell scripts parsing <bar@plt-0x20> should be extremely brittle and they should be avoided. If the programs need addresses, they should just parse the address part, not the stuff in angle quotes.
I have found someone who agrees with me that firstsym-x is awful and the behavior should not be replicated. Let me check if I can get more opinions tomorrow.
Jun 19 2019
Can you persuade git/svn to do a rename of the test rather than a delete and add? That would make the diff easier to see.
Didn't find a way to achieve that unless splitting the file rename part out. Seems it is how Git works (https://stackoverflow.com/questions/7938582/how-does-git-detect-similar-files-for-its-rename-detection),
- update comment