Page MenuHomePhabricator

Add lldb-mi/lldb-server test folders to PATH before in dotest.py
ClosedPublic

Authored by ki.stfu on Mar 10 2015, 9:42 AM.

Details

Summary

This patch allows not specify search path in each lldb-mi test. It makes tests easier.

This fix was requested by vharron.

All test pass on OS X.

Diff Detail

Repository
rL LLVM

Event Timeline

ki.stfu updated this revision to Diff 21595.Mar 10 2015, 9:42 AM
ki.stfu retitled this revision from to Add lldb-mi/lldb-server test folders to PATH before in dotest.py.
ki.stfu updated this object.
ki.stfu edited the test plan for this revision. (Show Details)
ki.stfu added a reviewer: vharron.
ki.stfu added subscribers: vharron, Unknown Object (MLST).
vharron edited edge metadata.Mar 10 2015, 5:25 PM

Can you make the requested changes?

test/dotest.py
933 ↗(On Diff #21595)

Maybe scriptPath should be renamed to lldbTestRoot, this would improve understanding

945 ↗(On Diff #21595)

Comment: Adding test/tools/lldb-mi to the path makes it easy to "import lldbmi_testcase" from the Mi tests

946 ↗(On Diff #21595)

Comment: Adding test/tools/lldb-server to the path makes it easy to "import lldbgdbserverutils" from the lldb-server tests

ki.stfu planned changes to this revision.Mar 10 2015, 10:32 PM
ki.stfu added inline comments.Mar 11 2015, 5:14 AM
test/dotest.py
933 ↗(On Diff #21595)

I think we should leave it as is, because scriptPath can be taken from env variable DOTEST_SCRIPT_DIR (see line 910).

If we do it, it will be strange why

lldbTestRoot = os.environ["DOTEST_SCRIPT_DIR"]
ki.stfu updated this revision to Diff 21692.Mar 11 2015, 5:24 AM

Add comments

ki.stfu updated this revision to Diff 21695.Mar 11 2015, 5:33 AM

Rebase against ToT

clayborg requested changes to this revision.Mar 11 2015, 10:38 AM
clayborg edited edge metadata.

A few rename changes and this looks good.

test/dotest.py
935 ↗(On Diff #21695)

Can we rename this to toolsLLDBMIPath?

936 ↗(On Diff #21695)

Can we rename this to toolsLLDBServerPath?

This revision now requires changes to proceed.Mar 11 2015, 10:38 AM
ki.stfu added inline comments.Mar 11 2015, 12:07 PM
test/dotest.py
935 ↗(On Diff #21695)

Why? Look at lines 965-967. I think I follow for the naming convention.

Anything that is an anocronym that is in the middle of a name should be all caps. So feel free to update the other variables that might not be following this convention.

LLDB and MI should always be caps.

ki.stfu updated this revision to Diff 21803.Mar 12 2015, 12:33 AM
ki.stfu edited edge metadata.

Rename toolsLldbMiPath/toolsLldbServerPath to toolsLLDBMIPath/toolsLLDBServerPath

This revision was automatically updated to reflect the committed changes.

Phabricator isn't allowing me to select "Accept Revision" for some reason...