Added some reviewers based on the git log of tests that are affected by this change. The change itself is a one-liner that simply switches the default value of a command-line option in the backend. But it affects control flow and each of the four affected tests needs to be checked. It is possible that some tests become redundant due to the way the control flow is now organized.
Can we come out with a name that is closer to what was implemented, like amdgpu-unify-loop-exits, or even amdgpu-normalize-loops(cfg)? "workarounds" is kind of misleading.
This one option controls more than one pass. The intention of naming this option is to indicate to the user that additional things are being done to work around known structurizer limitations. Each of these pass is used to avoid a specific situation where the structurizer is know to fail. We could have one option per pass like the names you suggest, but that sounds like overkill. We might even add more passes to the set of workarounds in the future.