This is an alternative proposal for supporting address space in intrinsics. It's applicable for any intrinsic, not only masked-load-store.
Related to http://reviews.llvm.org/D17270
I this proposal I add non-zero address space suffix to intrinsic name. The original name looks like
The same name with address space 1 :
(I did not update documentation. I'll do this if the proposed change looks reasonable for reviewers ).