Page MenuHomePhabricator

Fix build of lldb on Mavericks after svn rev.243511
ClosedPublic

Authored by dawn on Jul 30 2015, 4:16 PM.

Details

Summary

This patch adds a test for ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED around the code which requires 10.10 support to link. Without this, lldb gets unresolved references to _csr_check and _rootless_allows_task_for_pid. This patch resolves http://reviews.llvm.org/rL243511.

Diff Detail

Event Timeline

dawn updated this revision to Diff 31085.Jul 30 2015, 4:16 PM
dawn retitled this revision from to Fix build of lldb on Mavericks after svn rev.243511.
dawn updated this object.
dawn added reviewers: jasonmolenda, clayborg.
dawn set the repository for this revision to rL LLVM.
dawn added a subscriber: lldb-commits.
jasonmolenda accepted this revision.Jul 30 2015, 4:19 PM
jasonmolenda edited edge metadata.

Looks good. I suspected this wouldn't link on older systems.

This revision is now accepted and ready to land.Jul 30 2015, 4:19 PM
This revision was automatically updated to reflect the committed changes.