Naming is somewhat inconsistent. I think 'amdgcn' refers to 'graphics core next', but the gfx10 cards are branded 'radeon dna'. Changing to a new library seems a relatively good point to rename it.
^ would like to call this 'load'
What is this? Symbol is undefined on nvptx as far as I can tell. Amdgpu fails to link without a definition.
Suggestion offline is that delaying the check in clang for these builtins until template instantiation would make them usable from a function template, worthwhile usability improvement