HomePhabricator

[DWARF] Allow toolchain to adjust specified DWARF version.

Authored by tra on Dec 3 2020, 1:48 PM.

Description

[DWARF] Allow toolchain to adjust specified DWARF version.

This is needed for CUDA compilation where NVPTX back-end only supports DWARF2,
but host compilation should be allowed to use newer DWARF versions.

Differential Revision: https://reviews.llvm.org/D92617