- User Since
- Apr 6 2016, 10:26 AM (249 w, 4 d)
Mon, Jan 11
Sat, Jan 9
Fri, Jan 8
Thu, Jan 7
Wed, Jan 6
Address reviewer comments. Extend test to check for no function sections.
The demangler code for suffixes that accepts either lowercase letters with underscore or numbers.
Fix a clang test to reflect the new change.
Tue, Jan 5
Mon, Jan 4
Tue, Dec 29
This change looks good to me but I would like @rnk to sign off. My opinion is that the change is simple enough.
Mon, Dec 28
Wed, Dec 23
Tue, Dec 22
Address reviewer comments.
Use part instead of bb. __part is more descriptive as the symbol can denote one or more basic blocks.
Mon, Dec 21
https://reviews.llvm.org/D73307#1932131 rnk@ mentioned this : "At a higher level, should this just be an IR pass that clang adds into the pipeline when the flag is set? It should be safe to rename internal functions and give private functions internal linkage. It would be less invasive to clang and have better separation of concerns. As written, this is based on the source filename on the module, which is accessible from IR. The only reason I can think of against this is that the debug info might refer to the function linkage name, but maybe that is calculated later during codegen."
I too was currently working on changing the raw linkage names, DW_AT_linkage_name, and was about to send out a patch along these lines :). Thanks for doing this! I will take a look at it.
Dec 12 2020
Dec 10 2020
Dec 4 2020
Sorry just one more thing which is a bit concerning:
LGTM. I checked it completely and the patch makes total sense to me.
Dec 3 2020
You said : "The name -mpie-copy-relocations is misleading  and does not capture the idea that this option can actually apply to all of -fno-pic,-fpie, ..."
Nov 25 2020
Nov 6 2020
Thanks for fixing this!
Nov 5 2020
Abandoning it because D83655 fixes it by splitting up gcc_except_table.
Nov 4 2020
Nov 3 2020
Oct 29 2020
Oct 26 2020
Address the following reviewer comments:
Oct 23 2020
Oct 22 2020
Change the prefix to "__uniq" like mtrofin@ suggested.
Oct 21 2020
Oct 20 2020
Address reviewer comments, move the negative check into CodeGen.
Oct 19 2020
Incorporating snehasishk@'s suggestion that "llvmuniq" is a better prefix for tools to search on.
Oct 17 2020
Prepend ".uniq." to the module name hash.
Oct 16 2020
Remove checks of valid options in frontend as codegen already does that.
Test the error messages in the driver and the frontend.
Address reviewer comments, add UNSUPPORTED: and test one more permutation (the exact reverse) for basic block reordering.
Oct 15 2020
Based on dblaikie's comment, remove the driver check for file exists completely as the front-end will do this anyways and report an appropriate error upon failure.
Fix the diff.
Oops, let me fix the diff first.
Fix a typo.