Page MenuHomePhabricator

reidtatge (Reid Tatge)
User

Projects

User does not belong to any projects.

User Details

User Since
May 7 2020, 4:13 PM (19 w, 5 d)

Recent Activity

Aug 4 2020

reidtatge accepted D84888: [mlir] [VectorOps] Add expand/compress operations to Vector dialect.
Aug 4 2020, 10:36 AM · Restricted Project
reidtatge added inline comments to D84888: [mlir] [VectorOps] Add expand/compress operations to Vector dialect.
Aug 4 2020, 10:36 AM · Restricted Project

Jul 29 2020

reidtatge accepted D84699: [mlir] [VectorOps] [integration_test] Sparse matrix times vector (jagged SAXPY version).

Nice. LGTM

Jul 29 2020, 12:49 PM · Restricted Project

Jun 29 2020

reidtatge accepted D82674: [mlir] [VectorOps] Extend vector reduction integration test with reassoc=true cases..
Jun 29 2020, 12:28 PM · Restricted Project

Jun 19 2020

reidtatge accepted D82144: [mlir] [VectorOps] Improve vector.constant_mask lowering.

LGTM

Jun 19 2020, 10:18 AM · Restricted Project

Jun 9 2020

reidtatge accepted D81503: [mlir] [VectorOps] Handle 'vector.shape_cast' lowering for all cases.

Regarding the loop starting on line 1502: it bugs me that there's no readable/efficient way to assert "don't do this on the first (or last) iteration".

Jun 9 2020, 3:28 PM · Restricted Project

May 14 2020

reidtatge accepted rGfb2c4d50f142: [mlir] [VectorOps] Implement vector.constant_mask lowering to LLVM IR.
May 14 2020, 12:31 PM

May 11 2020

reidtatge committed rG334a4159eca0: [mlir][Vector] NFC - Rename vector.strided_slice into vector. (authored by reidtatge).
[mlir][Vector] NFC - Rename vector.strided_slice into vector.
May 11 2020, 2:36 PM
reidtatge closed D79734: [mlir][VectorOps] NFC - Rename vector.strided_slice into vector.extract_strided_slice.
May 11 2020, 2:35 PM · Restricted Project
reidtatge retitled D79734: [mlir][VectorOps] NFC - Rename vector.strided_slice into vector.extract_strided_slice from [mlir][Vector] NFC - Rename vector.strided_slice into vector.extract_strided_slice to [mlir][VectorOps] NFC - Rename vector.strided_slice into vector.extract_strided_slice.
May 11 2020, 2:35 PM · Restricted Project
reidtatge retitled D79734: [mlir][VectorOps] NFC - Rename vector.strided_slice into vector.extract_strided_slice from Rename vector.strided_slice into vector.extract_strided_slice to [mlir][Vector] NFC - Rename vector.strided_slice into vector.extract_strided_slice.
May 11 2020, 2:35 PM · Restricted Project
Herald added a reviewer for D79734: [mlir][VectorOps] NFC - Rename vector.strided_slice into vector.extract_strided_slice: aartbik.
May 11 2020, 11:50 AM · Restricted Project