The index type does not have a bitsize and hence the size of corresponding allocations cannot be computed. Instead, the promotion pass now has an explicit option to specify the size of index.
Just a question about the naming: bitWidth or bitwidth? It seems that there is no consistency in the naming in the whole project. Wouldn't it make sense to have only one name?