Part of the refactor discussed in:
It would be great to have more consistency wrt. naming of patterns and passes but this is a step in the right direction.
Left comments for further improvements but those need not be in this change.
Why are these in a header file?
Should we aim for a somewhat standardized name for the patterns themselves? Like BufferizeLinalgOpConverter or LinalgOpBufferizer?
Do we keep the name TypeConversionPatterns? Or should this also become BufferizeOpConversionPatterns? I think the latter is also already in use.
This comment is off.
Could this also be renamed?
Here, too. Also scrap the TODO?
The BufferizeTypeConverter allows to configure how types should be rewritten.
@herhut sounds good to me. Maybe we should aim for LinalgOpBufferizer.
I guess it makes sense to unify these names in a way that they express their association to the internal Bufferize functionality.
This comment is out-of-date and should be adapted.